View Issue Details

IDProjectCategoryView StatusLast Update
0000983Enderal[All Projects] Soundpublic2019-03-11 15:30
ReporterSmilymilkmanAssigned Tostuemper 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Summary0000983: Low music
DescriptionMusic starts off normally when loading game and then it fades into the backround still audiable when effects is turned down. I revisited an earlier save and it had normal sounding music so i don't know really what to make off it.
TagsNo tags attached.
VersionEnglish

Relationships

related to 0000996 closed Music will only play on start menu 

Activities

Smilymilkman

2019-02-24 18:14

reporter  

quicksave.ess.bak (5,558,285 bytes)
quicksave.skse (3,683 bytes)

Riemenschneider

2019-02-25 05:47

reporter   ~0002120

Same problem for me, music plays normally for 2-3 seconds while loading save file, then fades to very low volume during the loading screen.
Loading an older save file does not help.

I tried the console command removemusic for the following:

_00E_SilenceLongTransitionHighPriority 10486D
_00E_SilenceAbruptHighPriority C08EE
_00E_SilenceLongTransitionHighPriority 12EAC6
_00E_SilenceTransitionHighPriority DE718
_00E_SilenceTransitionLowPriority EAC97
_00E_SilenceTransitionLowPriority02 13C973

about 10-20 times each, which did not solve the problem. Neither did verifying game files in Steam or restarting the game/PC.

Not 100% sure what triggered it, last locations I visited were Old Askamahn, Powder Desert and Duneville.

Riemenschneider

2019-02-26 00:32

reporter   ~0002151

This is really weird, I experimented a bit with OP's and my own saves and found out several things:

Quicksaving during combat on a sound-bugged file (e.g. the one OP provided) and reloading that quicksave reactivates combat music, but a random one will be played.
This can include a combat theme that never plays in that location. Likely the one with which the bug was introduced into the save file?
So it's likely caused by quicksaving/loading during combat.
The random/unfitting battle theme is different for OP and me, mine is "Prey-Beutezug", for me it will also play e.g. in Ark or the Undercity, where it's never supposed to play.

Now it gets a bit more weird.
Reactivating the combat music by that method fixed music (in general) on pre-bug save files for me.
If you reactivate combat music by quicksave/reloading during battle and load another save file (with sound bug) that is NOT in combat, the unfitting combat music will play.
Other music will still not work though.
If you load the exact same (out of combat) save again, it will be silent again.

On sound-bugged files, the sound effects for discovering a new location and level-up don't play in game, but if you quit to main menu it will instantly play there (?)
So it somehow gets queued behind whatever is blocking the regular in-game music I guess?

Can anyone test it it behaves the same way for you guys? I attached 2 save files to this:
- 008: out of combat, right in front of an undiscovered location
- quicksave: in combat

Saves Soundbug.zip (4,982,849 bytes)

Riemenschneider

2019-02-26 01:54

reporter   ~0002166

Here's a save file in an earlier stage of the bug. As you load the file, overworld music still works.

If you fight the next group of enemies (not moving, just casting 3 times on that file will do that) the combat music will start to play, but doesn't stop any longer - afterwards all music is gone.
Moving ahead to discover the location "queues" the sound and it will only play if you return to main menu.

If you don't fight that group of enemies, but use e.g. "Return to Sun Temple" scroll and attack anyone there, combat music will never play, same in other locations like Frostcliff Tavern or Undercity.
If you start a fight there (no combat music), but return to the original group of enemies afterwards, THERE the combat music works again (plays once, no music + queued location sound afterwards). Weird.

Saves Soundbug Next Fight.zip (2,117,779 bytes)

Riemenschneider

2019-02-26 02:05

reporter   ~0002167

So it seems like the "no combat music, but overworld still works" is a pre-state of this bug, until you get to a fight which 'forces' combat music to start (?) like the one I provided in my last post, which will then trigger the "no music at all"-bug.

Krag

2019-02-27 00:12

reporter   ~0002193

Unfortunately, I'm running into the same issues as Riemenschneider, the music is all gone from my game as well.

Save 16 - Darius Heartland 30.59.35.ess (4,779,068 bytes)
Save 16 - Darius Heartland 30.59.35.skse (3,755 bytes)

Riemenschneider

2019-02-27 02:23

reporter   ~0002199

Enemy "Yogosh" (ID: 000954d3 baseID: 000954d9 area "Old Yogosh") triggers forced combat music on my bugged file, which does not stop after enemy has been defeated. As you have to kind of start this fight manually, it seems to be coded in a different way than regular overworld/combat music.

gavrant

2019-02-27 07:26

developer   ~0002219

@Krag, the following console command helped me with your Save 16:
removemusic _00E_SilenceLongTransitionHighPriority

Note that combat music still won't be played in this location. Regular combat music is not played if the enemies are 5+ levels below you (unless they are bosses or at level 30+), and, for example, the wolves right in front are level 10 against your level 25.

Also note that after applying the removemusic command above, ambient music may still disappear for some time if you venture further forward. It's normal and happens in transitional zones between two "regions". The music will start playing again as you approach the Farmer's Coast settlement ahead or turn back to Ark.

gavrant

2019-02-27 08:14

developer   ~0002221

@Riemenschneider, your problem with combat music in Saves Soundbug Next Fight.zip is unrelated to Krag's issue and probably to Smilymilkman's (OP) one. I can upload you a "quick and dirty" temporal fix before the official one come out.

rtf54

2019-02-27 11:58

reporter   ~0002225

@gavrant removemusic _00E_SilenceLongTransitionHighPriority worked for my issue as well. (0001011)

Riemenschneider

2019-02-27 13:19

reporter   ~0002231

@gavrant sounds great! What do I need to do? Thanks a lot for your time. I'm attaching my current save file just in case, but if it only works with the one I already uploaded, that's fine as well.

Current Save.zip (1,976,531 bytes)

rtf54

2019-02-27 13:23

reporter   ~0002232

Correction: the console command seemed to fix everything except combat music. So far it hasn't played for some reason.

gavrant

2019-02-27 13:34

developer   ~0002234

@Riemenschneider, @rtf54 : the "hotfix" for combat music is attached to this note.
Unpack the .zip to your ...\Steam\steamapps\common\Enderal\Data folder, load a bugged save with combat music not playing, wait for about 5 seconds, then try to fight someone.

If it helps, keeps the two files ("scripts" folder, _00e_epupdatefunctions.pex and _00e_playerfunctions.pex) until the next official Enderal update (if the fix will be included into it). After that it's better to delete those files to avoid conflicts with the "official" versions of the scripts.

Enderal - Combat Music Fix.zip (7,361 bytes)

Riemenschneider

2019-02-27 13:57

reporter   ~0002235

@gavrant works like a charm! Instantly got all overworld and combat music back. Thanks so much for your help.

rtf54

2019-02-27 14:37

reporter   ~0002237

That indeed did it, thanks!

stuemper

2019-03-01 21:01

administrator   ~0002305

Fixed for the next patch by gavrant.

Issue History

Date Modified Username Field Change
2019-02-24 18:14 Smilymilkman New Issue
2019-02-24 18:14 Smilymilkman File Added: quicksave.ess.bak
2019-02-24 18:14 Smilymilkman File Added: quicksave.skse
2019-02-25 05:47 Riemenschneider Note Added: 0002120
2019-02-26 00:32 Riemenschneider File Added: Saves Soundbug.zip
2019-02-26 00:32 Riemenschneider Note Added: 0002151
2019-02-26 01:54 Riemenschneider File Added: Saves Soundbug Next Fight.zip
2019-02-26 01:54 Riemenschneider Note Added: 0002166
2019-02-26 02:05 Riemenschneider Note Added: 0002167
2019-02-27 00:12 Krag File Added: Save 16 - Darius Heartland 30.59.35.ess
2019-02-27 00:12 Krag File Added: Save 16 - Darius Heartland 30.59.35.skse
2019-02-27 00:12 Krag Note Added: 0002193
2019-02-27 00:21 stuemper Relationship added related to 0000996
2019-02-27 00:30 stuemper Relationship added has duplicate 0001011
2019-02-27 02:23 Riemenschneider Note Added: 0002199
2019-02-27 07:26 gavrant Note Added: 0002219
2019-02-27 08:14 gavrant Note Added: 0002221
2019-02-27 11:58 rtf54 Note Added: 0002225
2019-02-27 13:19 Riemenschneider File Added: Current Save.zip
2019-02-27 13:19 Riemenschneider Note Added: 0002231
2019-02-27 13:23 rtf54 Note Added: 0002232
2019-02-27 13:34 gavrant File Added: Enderal - Combat Music Fix.zip
2019-02-27 13:34 gavrant Note Added: 0002234
2019-02-27 13:57 Riemenschneider Note Added: 0002235
2019-02-27 14:37 rtf54 Note Added: 0002237
2019-02-27 22:43 stuemper Relationship deleted has duplicate 0001011
2019-03-01 21:01 stuemper Assigned To => stuemper
2019-03-01 21:01 stuemper Status new => resolved
2019-03-01 21:01 stuemper Resolution open => fixed
2019-03-01 21:01 stuemper Note Added: 0002305
2019-03-11 15:30 stuemper Status resolved => closed