View Issue Details

IDProjectCategoryView StatusLast Update
0001736Enderal[All Projects] Questpublic2019-12-01 00:44
ReporterjackspAssigned Tostuemper 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0001736: I gave the First Seer the fake human heart and my mistrust with the Rhalata lowered instead
DescriptionI just finished the quest from the Rhalata questline and wanted to see if giving The First Seer the fake heart would indeed lower the trust with the faction.

Imagine my reaction when I found out that it instead raised it!

I went into the CK and found the two global variables that indicate the mistrust (so lower the better) and loaded up the save to see that while I had FS_NQR03_GivenFakeHeart set to 1.00 the value of _00E_FS_NQR_RhalataMistrust was set to 10 (down from 15)
I then loaded a previous save, killed Sister Pride and went back to the First Seer and completed the quest. Checked the vars and FS_NQR03_GivenFakeHeart was set to 0.00 while _00E_FS_NQR_RhalataMistrust remained 15!

I maybe thought it was intended or that maybe the variable was mislabeled but I checked where it was used and there's a dialogue line which indeed shows that if it's above 15 Tharael isn't happy (and I guess not even the Father is..)

Please also check the other quests to make sure that they work as intended, as I won't progress this quest line till this bug is fixed. Thanks!
Steps To ReproduceKill Sister pride and take her heart or don't and finish the quest, then check the mentioned variables in the console.
TagsNo tags attached.
VersionEnglish

Activities

jacksp

2019-10-13 13:58

reporter  

fake heart.zip (4,771,414 bytes)
real heart.zip (4,800,845 bytes)
real heart given.jpg (757,590 bytes)
fake heart given.jpg (643,508 bytes)

stuemper

2019-10-13 18:38

administrator   ~0003232

Thanks for pointing it out. I found one other case where the mistrust got lowered instead of raised, both will be fixed in the next patch.

Issue History

Date Modified Username Field Change
2019-10-13 13:58 jacksp New Issue
2019-10-13 13:58 jacksp File Added: fake heart.zip
2019-10-13 13:58 jacksp File Added: real heart.zip
2019-10-13 13:58 jacksp File Added: real heart given.jpg
2019-10-13 13:58 jacksp File Added: fake heart given.jpg
2019-10-13 15:22 stuemper Priority immediate => normal
2019-10-13 15:22 stuemper Assigned To => stuemper
2019-10-13 15:22 stuemper Status new => assigned
2019-10-13 18:38 stuemper Status assigned => resolved
2019-10-13 18:38 stuemper Resolution open => fixed
2019-10-13 18:38 stuemper Note Added: 0003232
2019-12-01 00:44 stuemper Status resolved => closed