View Issue Details

IDProjectCategoryView StatusLast Update
0001729Enderal[All Projects] UIpublic2019-10-12 23:38
ReportersnigelhastenAssigned Tostuemper 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Summary0001729: "Entropic craze" shows as a temporary effect in the ui(although its a permanent effect from the dark keeper affinity)
DescriptionThe affinity for dark keeper is shown to have a duration of 15/14 sec when it should be a permanent effect. I have tested and at least the "Devour soul" active effect works but I have not tested the other passive effects.

Below is a picture i've taken to show what i mean.
https://gyazo.com/624ba6b9b065a439e9cdb30b68883ce4
It says 15sec left at one spot and 14 at another but it should not have a timer at all. The most annoying thing is that it shows up in the right corner with the temporary effects but its timer is not moving. It shows up in the corner as an active effect because the duration is lower than 180sec but it is an affinity so it should be permanent.
Steps To ReproduceJust start the save and it should be in the corner or check active effects.
TagsNo tags attached.
VersionEnglish

Activities

snigelhasten

2019-10-07 18:50

reporter  

Saves.rar (1,966,569 bytes)

snigelhasten

2019-10-08 10:10

reporter   ~0003223

Also I don't know if it helps but I have the same issue on all my older saves that has the affinity aswell. Not just the newest which I attached in the report.

stuemper

2019-10-12 23:34

administrator   ~0003228

Last edited: 2019-10-12 23:38

View 2 revisions

Fixed the following things:
1) Reduced multiple entries of the affinity to only one in the active magic effect menu.
2) Removed unnecessary/broken code.
3) Fixed the issue that it is displayed with the tempory effects in the top right corner.
4) Fixed the issue that one entry was displayed with a duration of 14-15 sec in the active magic effect menu.
5) Fixed the missing textures of the effect in the active magic effect menu.

The affinity itself was working, just its whole UI setup was nonsense.

Issue History

Date Modified Username Field Change
2019-10-07 18:50 snigelhasten New Issue
2019-10-07 18:50 snigelhasten File Added: Saves.rar
2019-10-07 22:45 stuemper Assigned To => stuemper
2019-10-07 22:45 stuemper Status new => assigned
2019-10-08 10:10 snigelhasten Note Added: 0003223
2019-10-12 23:34 stuemper Note Added: 0003228
2019-10-12 23:34 stuemper Status assigned => resolved
2019-10-12 23:34 stuemper Resolution open => fixed
2019-10-12 23:38 stuemper Note Edited: 0003228 View Revisions