View Issue Details

IDProjectCategoryView StatusLast Update
0001272Enderal[All Projects] Balancingpublic2019-03-25 05:55
ReportercloudropisAssigned Tostuemper 
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionno change required 
Summary0001272: armor sets spectralized on an apparition (phasmalism tree) don't always activate set bonus
DescriptionIf you use spectralization to equip an apparition with an armor set, the bonus that comes from that set sometimes activate, sometimes don't. They require multiple cycles of summoning/unsomming the apparition with the dedicated talent before attributes get adjusted accordingly. More thorough testing done here:

https://www.reddit.com/r/enderal/comments/b078v2/buginformativeinconsistent_attributes_after/

Since doing that testing, I've switched over to another save file and went through the spectralization process again with the same armor set plus some other unrelated items, and now no matter how many times I dismiss and summon the apparition, the set bonus don't appear correctly anymore.
Steps To ReproduceUse the phasmalism talent to summon an apparition with an armor set (ie, ratcatcher) equipped, check its attributes and note how it's a dice roll, on every summoning, wether set bonus effects take place or not
TagsNo tags attached.
VersionEnglish

Activities

stuemper

2019-03-25 05:55

administrator   ~0002614

The normal enchantments on the armor pieces might work on apparitions but not the set bonuses since they are only intended for the player.

Issue History

Date Modified Username Field Change
2019-03-12 17:06 cloudropis New Issue
2019-03-25 05:55 stuemper Assigned To => stuemper
2019-03-25 05:55 stuemper Status new => closed
2019-03-25 05:55 stuemper Resolution open => no change required
2019-03-25 05:55 stuemper Note Added: 0002614